Jump to content
odrezet

LFOB : Textures Manquantes

Recommended Posts

Hello,

 

Je précise tout de suite : C'est une installation externalisée, donc je sais que c'est moi qui ai loupé quelque chose (Entre la chaise et le clavier ...) :D :rolleyes:

 

1- J'ai installé la scène dans un dossier "Leurre", qui contient Prepare3D.exe et Terrain.dll

 

Edit : à la fin de l'installation il y a un message  d'erreur qui indique que des fichiers seront installés dans le dossier par défaut ... Mais ... P3Dv4 ? P3Dv5 ? Comment identifier ces fichiers ? :oops:

 

2- J'ai  copié tous les dossiers dans le dossier ADDONS externalisé.

3- J'ai modifié les fichiers CFG (effects, fonts, gauges, simobjects, sound et texture) en ajoutant l'entrée nécessaire vers ce dossier externalisé.

 

Et j'obtiens ça :

 

uAgiJeA.jpg

 

Merci pour votre aide !

 

 

Edited by odrezet

Share this post


Link to post
Share on other sites

Bonsoir,

il m'est arrivé une chose à peu près similaire lorsque j'ai installé Picardie VFR3DA dernièrement;

J'ai externalisé la scène également avec le leurre Prepare3D.exe, et j’ai eu le même message d'erreur à la fin de l'installation!

En volant sur Picardie, les façades des maisons étaient toutes noires... ils manquaient donc des textures. Je crois d'ailleurs qu'un membres de ce forum à eu la même mésaventure, et à posté des images montrant le souci (Michel78320 dans Picardie VFR Addons! page 1 et 2) Il disait ceci:

 

"Toujours noir.

 

Mais j'ai trouvé : une erreur d'inattention lors de l'externalisation.  :oops:

Les textures de l'autogen Picardie manquaient dans le dossier Texture de P3D.

 

Tout est rentré dans l'ordre.  "

 

L'installateur a créer un dossier Texture dans l'externalisation et y a copié des fichiers du type "agn_pic_xxxxx.bmp" au lieu de les copier dans le dossier texture de Prepar3D v4;

Il a suffit de les déplacer au bon endroit, et effectivement tout est rentré dans l'ordre.

 

Voilà! je ne sais pas si c'est du même ordre, mais si cela peut aider...

 

Philippe

 

Share this post


Link to post
Share on other sites

Sur ton screen, je vois qu'en plus du problème de Tarmac foncé, tu as également des façades de maisons non texturées (noire, sauf les toitures)...

Share this post


Link to post
Share on other sites

@nico_38 Un grand merci ! J'ai bien récupéré toutes mes textures (façades maisons noires). Quant au tarmac foncé, je croyais que cela était l'apanage de P3Dv5 ? En revanche, je crois qu'il en manque des "bouts" ... Ce qui est moins problématique que les façades noires ! 

 

Il reste une chose que je ne comprends pas : Le fichier texture.cfg de P3Dv5 étant modifié, et  le dossier texture du dossier addons externalisé contenant les fameux fichiers, ne devrait-il pas les trouver ? N'est-ce pas là la raison de ces modifications ?  

 

Le fichier texture.cfg en question :

[Entry.0]
PATH=Texture
TYPE=Global
TITLE=Default Textures
ACTIVE=true
REQUIRED=true
[Entry.1]
PATH=Scenery\Global\Texture
TYPE=Global
TITLE=Default Global Scenery Textures
ACTIVE=true
REQUIRED=true
[Entry.2]
PATH=Scenery\World\Texture
TYPE=World
TITLE=Default World Textures
ACTIVE=true
REQUIRED=true
[Entry.3]
PATH=I:\P3Dv4_Addons\Texture
TYPE=World
TITLE=Default World Textures
ACTIVE=true
REQUIRED=true

bAGLfju.jpg

 

3SU1Jkt.jpg

 

w42b2K1.jpg

Edited by odrezet

Share this post


Link to post
Share on other sites

C'est également comme cela que je fait et ça fonctionne bien!

Personnellement je suis en P3D 4.5 mais je ne crois pas que la V5 soit différente de ce point de vue; Ce serait idiot!

Il va falloir faire appel à certain "cadors" de ce forum pour éclaircir ces "zones d'ombres", si je puis dire...

 

A suivre!

Share this post


Link to post
Share on other sites

Je confirme que ces textures sont bien présentes dans le dossier texture externalisé. Que ce dossier est bien présent dans texture.cfg ... Mais les maisons ont leurs façades noires.Si je copie ces textures dans le dossier texture de P3D, tout est nickel.

 

Je vais relire l'article de Filipo sur le sujet, pour vérifier une nouvelle fois si par hasard je n'aurais pas manqué quelques chose !

Share this post


Link to post
Share on other sites

Salut Jean-Luc :)

Ah tu me rassures ! Je ne serais donc pas que mauvais ... :)

 

Bon, maintenant je pouvoir injecter d'autres scènes France VFR dans ce P3Dv5 et voir ce que ça donne ...

Share this post


Link to post
Share on other sites
Il y a 5 heures, odrezet a dit :

Je confirme que ces textures sont bien présentes dans le dossier texture externalisé. Que ce dossier est bien présent dans texture.cfg ... Mais les maisons ont leurs façades noires.Si je copie ces textures dans le dossier texture de P3D, tout est nickel.

 

Je vais relire l'article de Filipo sur le sujet, pour vérifier une nouvelle fois si par hasard je n'aurais pas manqué quelques chose !

Salut Olivier 

Oups j'avais mal lu ton retour. Ce que j'ai écrit ci-dessous ne fait que confirmer ce que tu as dit sans apporter de solution. Désolé ;)

 

 

C'est sûrement parce qu'elles sont externalisées. Remets les dans le répertoire par défaut et il y a de fortes chances pour que ça fonctionne.  J'ai déjà eu le tour avec des AD italiens entre autres. Ça m'a conduit à ne plus externaliser les textures, les effets, les sons...

Edited by Philippe 02

Share this post


Link to post
Share on other sites

Salut Philippe :)

 

J'ai copié les fameux fichiers Dans le dossier Texture de P3Dv5.

C'est un comporte étrange de P3D, qui incite à externaliser, mais semble ne pas tenir compte de tous les éléments.

 

Pour l'instant, Le soldat Picardie est sauvé !!! :)

 

Merci pour ton message et ta confirmation !

Share this post


Link to post
Share on other sites

Bonjour odrezet

Ton fichier texture.cfg fait apparaitre 2 fois le même title (TITLE=Default World Textures) [Entry.2] et [Entry.3]

C'est peut être la raison de la non prise en compte.

 

Pour info je ne touche pas aux fichiers qui sont dans program data.

En revanche dans C:\Users\Name\AppData\Roaming\Lockheed Martin\Prepar3D v5

je mets tous mes propres fichiers personnalisés (effects.cfg, gauges.cfg, simobjects.cfg, DLL.XML, …)

Au lancement, P3D concatène les fichiers de mêmes noms pour n'en traiter qu'un seul.

Avec une sauvegarde de ces quelques fichiers, ainsi que du dossier "Controls" et de scenery.cfg on peut faire un nettoyage intégral suivi d'une réinstallation totale et tout retrouver en quelques secondes.

Mais bien sur, chacun gère à sa façon.

MichelP

 

 

 

 

Share this post


Link to post
Share on other sites

Bonjour Michel,

 

Merci pour ces pistes que je vais essayer d'explorer aujourd'hui !

L'idée étant effectivement, de pouvoir repartir d'une installation "fraîche" en quelques instants ...

 

Olivier

Share this post


Link to post
Share on other sites

Bonjour.  :)

 

Comme ces histoires de façades noire m'intriguaient, j'ai fait quelques essais.

 

- Il est tout à fait possible de mettre des textures agn_pic_xxx.bmp dans un dossier texture externalisé.

(j'ai désactivé les textures, vérifié que les façades devenaient noires, puis je les ai mises dans le dossier Texture externalisé : les façades sont de nouveau correctes)

 

- Le problème d'Olivier vient probablement d'un nom "Title=" qui n'est pas unique.

 

- Il me semble que le type doit être Global plutôt que World.

 

Normalement, on ne soucie pas de ces textures qui sont habituellement installées par AGX dans le dossier Texture de P3D (donc très facilement ré-installables si besoin).

Hélas, il me semble que la version 2.13 de AGX ne les installe pas, bien qu'elle remette celles des autres régions. Oubli de France VFR ? :rolleyes:

 

Tout est parfaitement clair, il me semble. 8-)

Share this post


Link to post
Share on other sites

Bonjour Michel,

 

A priori, oui, tout est clair. :)

 

Hier soir j'ai pu voler, avec une belle fluidité, que ce soit sur des scènes FVFR (LFOB, LFQT, LFPG), ou ORBX (KMRY, SYD).

Avec P3Dv4.5 (HF2), LFPG était compliquée à utiliser. Hier, belle fluidité, Météo ASP3D activée ...

 

Ce serait presque le meilleur des mondes, si ... Depuis ce matin, il me manque bien des bâtiment un peu partout !!! (Scènes FVFR) ... Je ne crois pas avoir fait de manipulation autres, entre le moment où j'ai éteint le PC, et où je l'ai démarré ce matin. C'est un poil fustrant, surtout quand on commence à goûter à des vols fluides, beaux, et qui permettent de belles évasions !

 

Exemple à LFPG :

 

M6IMRNo.jpg

 

Ga5dmaz.jpg

 

Je copierai 100 fois : Ne touche plus à rien si ça marche !!! :oops:

 

Edited by odrezet

Share this post


Link to post
Share on other sites

Salut,

 

Les bâtiments sont revenus ... Soucis de scenery.cfg généré par Lorby-Si. J'ai utilisé l'option de correction, et depuis c'est ok.

Je vais tester Languedoc-Roussillon, puis je pourrai enfin déployer le reste des scènes.

 

Edit : le scenery.cfg a vraiment une drôle de tête, entre Lorby-SI et ORBX ... 

Edited by odrezet

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...